2014年10月12日日曜日

3Dプリンタの修理

 
急に3Dプリンタさんの具合が悪くなりました。
かっつんかっつんと音がしてフィラメントがうまくエクストルーダに入っていきません。ヘッドの先端からは蜘蛛の糸のような細いPLAしか出ていません。
何度かやり直すのですが、最初は何とか動いているのですが、ある程度進むとかっつんかっつん言い出すのです。
昨日はほぼ完璧な仕事をしてくれただけに非常に心配な事態です。

とりあえず何がおきているのかさっぱりわかりませんでしたので、PCにつないで状態を見てみました。ちなみにいつもはSlic3rで作ったGコードをマイクロSDに入れてプリントしていました。私のプリンタには何もインジゲータがついていませんので、スタンドアロンでプリントしているときに調子が悪くなっても原因がわからないのです。

そもそも何をやっていたのかというと、これです。


昨日から新しく使い始めたPLAのフィラメントですが、まだドラムの芯材を作っておらず、フィラメントのほどけが非常に悪いのです。


ということで、こんな感じの(といってもなんだかわかりませんね)冶具を作ろうとしていたのですが、その矢先にトラブルが起きたのです。


今まで長々と使ってきたABSをPLAに換えたので、ABSが詰まっているのかなとも思いました。でも、昨日あれだけ調子よく動いていたのに、という思いもあります。

ということで、今までメンテらしいことは何もしてきませんでしたので、この機会にヘッドのオーバーホールをすることにしました。
これが私が使っている3Dプリンタさんです。RepRap Mendel Evolution。 DealExtreme でキットを購入し自分で組み立てました。ということで細部までわかっているつもりなのですが、ただひとつヘッドだけは中身がわからないのです。購入したときはすでに組みつけられていましたので。


キャリッジを外します。


ヘッドを外します。確かJヘッドというやつのはずです。ここから先はばらしたことがありません。
とりあえずこの先の分解をするために中に入っているPLAのフィラメントを取り除いたほうがよさそうです。ということで、この状態で通電し、ヘッドを暖めてフィラメントを抜き取ることにしました。

.....が、PCからヘッド昇温の命令を出してもなんか変です。気がつくと基板上のLEDが高速に点滅しています。さらにさらに良く見ると、PC上のヘッド温度が2℃になっています。「2℃!」これは絶対おかしい。おそらく熱伝対が切れています。


いずれにしてもオーバーホールはしたいので、とりあえずこのまま分解することにしました。
上部のチューブコネクタは簡単に外れます。
問題はこのパーツ。確か耐熱性のPEEKか何かのスーパーエンプラだったと思います。これがなかなか外れません。


ひょっとするとねじ切りではないのかも....などとどきどきしながらもいろいろとこねくっておりますと、何とか回り始めました。


外してみると、ちゃんとネジきりされていました。


問題の熱伝対を外します。なんという華奢な作り。


で、良く見ると...


切れていますね。上の線の中央付近です。


これでわかるかな。


新しいパーツを注文するのはやるとして、修理をどうするかです。場所が場所ですのであきらめようかとも思いましたが、やるだけやってみようと取り組んでみました。


ギボシから取り出したアルミのスリーブを使ってカシメて接続します。熱がかかるところですので半田は使えません。というか熱伝対にハンダを使うと電圧が暴れてわけがわからなくなります。


一部線を切断しましたので、その間は耐熱性のリード線でつなぎます。


もう一個ギボシを分解します。


こんな感じで熱伝対の出力とリード線を二箇所でつなぎます。


つないだところは耐熱性の高いカプトンテープでぐるぐる巻きにしておきます。買ってて良かったカプトンテープ。


ヘッドのほうも中を掃除して元通り組み付けます。炭化したフィラメントのカスが少し残ってましたが、それほどひどい状態ではありませんでした。


キャリッジに元通りに組み込みます。
ヒータと熱伝対は無理な力がかからないように配線の引き回しを工夫して再度取り付けました。
 

軸に乗せます。


ヒータと熱伝対配線。良くわかりませんね。


ということで、元通り動くようになりました。


 が、実はさらに問題がありました。
元通り組みつけて動かそうとしたのですが、やはりかっつんかっつん言って動きません。今度は温度はちゃんと上がっています。動くはずなのですが....

で、考えることしばし。おそらくと思われる原因を思いつきました。それは熱伝対をギボシのアルミスリーブでカシメたところです。
熱伝対は異種金属の接合部分を熱することで発生する起電力を温度に換算することでセンサとして動作しますが、今回はもともとの熱伝対の材料(おそらくアロメルクロメルあたり)と配線の銅を接続するのにアルミを使いました。つまりこれまでの構成に対してアロメルかクロメルとアルミの接合が増えています。しかも先端に近いところが破断しましたのでアルミ部分も加熱されます。
この接合部分の起電力がもともとの電圧に対して加算側か減算側かはわかりませんが、いずれにしろ電圧が変化することが考えられます。これすなわち制御ボードが感知する(感知したつもりでいる)ヘッドの温度がずれることになるということです。
ということで、本来180℃で動かしていたPLAですが、結局205℃に設定するとフィラメントはスムースに押し込まれ、元通りうまく動きました。
真因がこれかどうかはわかりませんが、状況から考えてこの推論があっている可能性は高いと考えています。

【翌日追記】
交換パーツを探そうと思いいろいろと見ていると、どうも使われている温度センサは熱電対ではなくサーミスタのようです。100kΩなどと書いてあります。であれば、上の推論は頓珍漢な話になりますのでとりあえず削除しておきます。部品がきましたら改めてテストして報告したいと思います。

考えてみれば接続に極性がないので熱電対という考えはおかしいようにも思えます。
では原因はなんだったのか?温度センサでなければヒータか?今のところ良くわかりませんのでどちらも交換してみたいと思います。
ということで、中国に部品発注。しばらくは3Dプリンタさんはお休みです。

いずれにしても交換パーツを手に入れる必要があります。

当面だましながら動かしたいと思います。何とか修理が出来て良かったです。





0 件のコメント:

コメントを投稿